CVE-2016-7076

NameCVE-2016-7076
Descriptionsudo before version 1.8.18p1 is vulnerable to a bypass in the sudo noexec restriction if application run via sudo executed wordexp() C library function with a user supplied argument. A local user permitted to run such application via sudo with noexec restriction could possibly use this flaw to execute arbitrary commands with elevated privileges.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-707-1
NVD severityhigh (attack range: local)
Debian Bugs842507

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
sudo (PTS)jessie1.8.10p3-1+deb8u5vulnerable
jessie (security)1.8.10p3-1+deb8u4vulnerable
stretch1.8.19p1-2.1fixed
bullseye, sid, buster1.8.27-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
sudosource(unstable)1.8.18p1-1high842507
sudosourcewheezy1.8.5p2-1+nmu3+deb7u2highDLA-707-1

Notes

[jessie] - sudo <no-dsa> (Minor issue)
https://www.sudo.ws/alerts/noexec_wordexp.html
https://www.sudo.ws/repos/sudo/rev/e7d09243e51b
https://www.sudo.ws/repos/sudo/rev/7b8357b0a358
https://www.sudo.ws/repos/sudo/rev/167a518d8129
Might need as well: https://bugzilla.sudo.ws/show_bug.cgi?id=761

Search for package or bug name: Reporting problems