CVE-2016-7098

NameCVE-2016-7098
DescriptionRace condition in wget 1.17 and earlier, when used in recursive or mirroring mode to download a single file, might allow remote servers to bypass intended access list restrictions by keeping an HTTP connection open.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs836503

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wget (PTS)wheezy1.13.4-3+deb7u2vulnerable
wheezy (security)1.13.4-3+deb7u3vulnerable
jessie1.16-1+deb8u1vulnerable
stretch1.18-4fixed
sid1.19.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wgetsource(unstable)1.18-4low836503

Notes

[jessie] - wget <no-dsa> (Minor issue)
[wheezy] - wget <no-dsa> (Minor issue)
http://git.savannah.gnu.org/cgit/wget.git/commit/?id=9ffb64ba6a8121909b01e984deddce8d096c498d
http://git.savannah.gnu.org/cgit/wget.git/commit/?id=690c47e3b18c099843cdf557a0425d701fca4957

Search for package or bug name: Reporting problems