CVE-2016-7124

NameCVE-2016-7124
Descriptionext/standard/var_unserializer.c in PHP before 5.6.25 and 7.x before 7.0.10 mishandles certain invalid objects, which allows remote attackers to cause a denial of service or possibly have unspecified other impact via crafted serialized data that leads to a (1) __destruct call or (2) magic method call.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-749-1, DSA-3689-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)wheezy5.4.45-0+deb7u2vulnerable
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed
php7.0 (PTS)stretch7.0.19-1fixed
buster, sid7.0.26-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.6.26+dfsg-1high
php5sourcejessie5.6.26+dfsg-0+deb8u1highDSA-3689-1
php5sourcewheezy5.4.45-0+deb7u6highDLA-749-1
php7.0source(unstable)7.0.10-1high

Notes

PHP Bug: https://bugs.php.net/bug.php?id=72663
Fixed in 7.0.10, 5.6.25
http://www.openwall.com/lists/oss-security/2016/09/02/5
https://github.com/php/php-src/commit/20ce2fe8e3c211a42fee05a461a5881be9a8790e?w=1

Search for package or bug name: Reporting problems