CVE-2016-7134

NameCVE-2016-7134
Descriptionext/curl/interface.c in PHP 7.x before 7.0.10 does not work around a libcurl integer overflow, which allows remote attackers to cause a denial of service (allocation error and heap-based buffer overflow) or possibly have unspecified other impact via a long string that is mishandled in a curl_escape call.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php7.0 (PTS)stretch7.0.33-0+deb9u8fixed
stretch (security)7.0.33-0+deb9u10fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)(not affected)
php7.0source(unstable)7.0.10-1

Notes

- php5 <not-affected> (Only affects PHP 7)
PHP Bug: https://bugs.php.net/bug.php?id=72674
Fixed in 7.0.10
https://www.openwall.com/lists/oss-security/2016/09/02/5
https://github.com/php/php-src/commit/72dbb7f416160f490c4e9987040989a10ad431c7?w=1

Search for package or bug name: Reporting problems