CVE-2016-7141

NameCVE-2016-7141
Descriptioncurl and libcurl before 7.50.2, when built with NSS and the libnsspem.so library is available at runtime, allow remote attackers to hijack the authentication of a TLS connection by leveraging reuse of a previously loaded client certificate from file for a connection for which no certificate has been set, a different vulnerability than CVE-2016-5420.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1568-1, DLA-616-1
NVD severitymedium
Debian Bugs836918

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)stretch7.52.1-5+deb9u10fixed
stretch (security)7.52.1-5+deb9u13fixed
buster, buster (security)7.64.0-4+deb10u1fixed
bullseye, sid7.74.0-1.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsourcewheezy7.26.0-1+wheezy15DLA-616-1
curlsourcejessie7.38.0-4+deb8u13DLA-1568-1
curlsource(unstable)7.51.0-1836918

Notes

Only affects libcurl3-nss
http://seclists.org/oss-sec/2016/q3/419
https://curl.haxx.se/docs/adv_20160907.html

Search for package or bug name: Reporting problems