CVE-2016-7154

NameCVE-2016-7154
DescriptionUse-after-free vulnerability in the FIFO event channel code in Xen 4.4.x allows local guest OS administrators to cause a denial of service (host crash) and possibly execute arbitrary code or obtain sensitive information via an invalid guest frame number.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3663-1
NVD severityhigh (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
xen (PTS)wheezy4.1.4-3+deb7u9fixed
wheezy (security)4.1.6.lts1-8fixed
jessie4.4.1-9+deb8u9fixed
jessie (security)4.4.1-9+deb8u10fixed
buster, sid, stretch4.8.1-1+deb9u1fixed
stretch (security)4.8.1-1+deb9u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
xensource(unstable)4.6.0-1high
xensourcejessie4.4.1-9+deb8u7highDSA-3663-1
xensourcewheezy(not affected)

Notes

[wheezy] - xen <not-affected> (Versions 4.3 and earlier are not vulnerable)
http://xenbits.xen.org/xsa/advisory-188.html
Only affects Xen 4.4, as workaround it is marked as fixed in the first xen version entering unstable
after the 4.4 series.

Search for package or bug name: Reporting problems