CVE-2016-7164

NameCVE-2016-7164
DescriptionThe construct function in puff.cpp in Libtorrent 1.1.0 allows remote torrent trackers to cause a denial of service (segmentation fault and crash) via a crafted GZIP response.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs837338

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libtorrent-rasterbar (PTS)wheezy0.15.10-1fixed
wheezy (security)0.15.10-1+deb7u1fixed
jessie0.16.18-1vulnerable
stretch1.1.1-1fixed
buster, sid1.1.4-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libtorrent-rasterbarsource(unstable)1.1.1-1medium837338
libtorrent-rasterbarsourcewheezy(not affected)

Notes

[jessie] - libtorrent-rasterbar <no-dsa> (Minor issue)
[wheezy] - libtorrent-rasterbar <not-affected> (Vulnerable code not present, reproducer does not crash)
https://github.com/arvidn/libtorrent/issues/1021
https://github.com/arvidn/libtorrent/pull/1022
https://github.com/arvidn/libtorrent/commit/debf3c6e3688aab8394fe5c47737625faffe6f9e
Fixed upstream in 1.1.1.

Search for package or bug name: Reporting problems