CVE-2016-7166

NameCVE-2016-7166
Descriptionlibarchive before 3.2.0 does not limit the number of recursive decompressions, which allows remote attackers to cause a denial of service (memory consumption and application crash) via a crafted gzip file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-617-1, DSA-3677-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libarchive (PTS)wheezy3.0.4-3+wheezy1vulnerable
wheezy (security)3.0.4-3+wheezy6+deb7u1fixed
jessie (security), jessie3.1.2-11+deb8u3fixed
stretch3.2.2-2fixed
buster, sid3.2.2-3.1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libarchivesource(unstable)3.2.0-2medium
libarchivesourcejessie3.1.2-11+deb8u3mediumDSA-3677-1
libarchivesourcewheezy3.0.4-3+wheezy3mediumDLA-617-1

Notes

https://github.com/libarchive/libarchive/issues/660
(with reproducer) https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=207362
Fixed by: https://github.com/libarchive/libarchive/commit/6e06b1c89dd0d16f74894eac4cfc1327a06ee4a0
Fix improved by: https://github.com/libarchive/libarchive/commit/37649d274867edd2dd25d8a3057c3b6cd81ce83e

Search for package or bug name: Reporting problems