CVE-2016-7167

NameCVE-2016-7167
DescriptionMultiple integer overflows in the (1) curl_escape, (2) curl_easy_escape, (3) curl_unescape, and (4) curl_easy_unescape functions in libcurl before 7.50.3 allow attackers to have unspecified impact via a string of length 0xffffffff, which triggers a heap-based buffer overflow.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-1568-1, DLA-625-1
Debian Bugs837945

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)buster7.64.0-4+deb10u2fixed
buster (security)7.64.0-4+deb10u3fixed
bullseye7.74.0-1.3+deb11u3fixed
bullseye (security)7.74.0-1.3+deb11u2fixed
bookworm, sid7.85.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsourcewheezy7.26.0-1+wheezy16DLA-625-1
curlsourcejessie7.38.0-4+deb8u13DLA-1568-1
curlsource(unstable)7.51.0-1837945

Notes

Upstream advisory: https://curl.haxx.se/docs/adv_20160914.html
Upstream patch: https://curl.haxx.se/CVE-2016-7167.patch
Affected versions: libcurl 7.11.1 to and including 7.50.2
Not affected versions: libcurl < 7.11.1 and libcurl >= 7.50.3

Search for package or bug name: Reporting problems