CVE-2016-7180

NameCVE-2016-7180
Descriptionepan/dissectors/packet-ipmi-trace.c in the IPMI trace dissector in Wireshark 2.x before 2.0.6 does not properly consider whether a string is constant, which allows remote attackers to cause a denial of service (use-after-free and application crash) via a crafted packet.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-632-1, DSA-3671-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
wireshark (PTS)wheezy1.8.2-5wheezy18vulnerable
wheezy (security)1.12.1+g01b65bf-4+deb8u6~deb7u7fixed
jessie (security), jessie1.12.1+g01b65bf-4+deb8u11fixed
stretch2.2.6+g32dac6a-2fixed
buster, sid2.4.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
wiresharksource(unstable)2.2.0~rc1+g438c022-1medium
wiresharksourcejessie1.12.1+g01b65bf-4+deb8u9mediumDSA-3671-1
wiresharksourcewheezy1.12.1+g01b65bf-4+deb8u6~deb7u4mediumDLA-632-1

Notes

https://code.wireshark.org/review/gitweb?p=wireshark.git;a=commit;h=5213496250aceff086404c568e3718ebc0060934
https://www.wireshark.org/security/wnpa-sec-2016-55.html
https://code.wireshark.org/review/17289
Affected versions: 2.0.0 to 2.0.5
Fixed versions: 2.0.6

Search for package or bug name: Reporting problems