CVE-2016-7393

NameCVE-2016-7393
DescriptionStack-based buffer overflow in the aac_sync function in aac_parser.c in Libav before 11.5 allows remote attackers to cause a denial of service (out-of-bounds read) via a crafted file.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-644-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ffmpeg (PTS)stretch7:3.2.12-1~deb9u1fixed
stretch (security)7:3.2.14-1~deb9u1fixed
bullseye, sid, buster7:4.1.3-1fixed
libav (PTS)jessie6:11.12-1~deb8u1fixed
jessie (security)6:11.12-1~deb8u7fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ffmpegsource(unstable)7:2.4-1medium
libavsource(unstable)(unfixed)medium
libavsourcejessie6:11.6-1~deb8u1medium
libavsourcewheezy6:0.8.18-0+deb7u1mediumDLA-644-1

Notes

https://blogs.gentoo.org/ago/2016/08/20/libav-stack-based-buffer-overflow-in-aac_sync-aac_parser-c/
https://git.libav.org/?p=libav.git;a=commit;h=fb1473080223a634b8ac2cca48a632d037a0a69d

Search for package or bug name: Reporting problems