CVE-2016-7413

NameCVE-2016-7413
DescriptionUse-after-free vulnerability in the wddx_stack_destroy function in ext/wddx/wddx.c in PHP before 5.6.26 and 7.x before 7.0.11 allows remote attackers to cause a denial of service or possibly have unspecified other impact via a wddxPacket XML document that lacks an end-tag for a recordset field element, leading to mishandling in a wddx_deserialize call.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-749-1, DSA-3689-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)wheezy5.4.45-0+deb7u2vulnerable
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed
php7.0 (PTS)stretch7.0.19-1fixed
buster, sid7.0.22-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.6.26+dfsg-1high
php5sourcejessie5.6.26+dfsg-0+deb8u1highDSA-3689-1
php5sourcewheezy5.4.45-0+deb7u6highDLA-749-1
php7.0source(unstable)7.0.11-1high

Notes

PHP Bug: https://bugs.php.net/bug.php?id=72860
Fixed in 7.0.11, 5.6.26
https://github.com/php/php-src/commit/b88393f08a558eec14964a55d3c680fe67407712?w=1

Search for package or bug name: Reporting problems