CVE-2016-7418

NameCVE-2016-7418
DescriptionThe php_wddx_push_element function in ext/wddx/wddx.c in PHP before 5.6.26 and 7.x before 7.0.11 allows remote attackers to cause a denial of service (invalid pointer access and out-of-bounds read) or possibly have unspecified other impact via an incorrect boolean element in a wddxPacket XML document, leading to mishandling in a wddx_deserialize call.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-749-1, DSA-3689-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)wheezy5.4.45-0+deb7u2vulnerable
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed
php7.0 (PTS)stretch7.0.19-1fixed
buster, sid7.0.22-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)5.6.26+dfsg-1medium
php5sourcejessie5.6.26+dfsg-0+deb8u1mediumDSA-3689-1
php5sourcewheezy5.4.45-0+deb7u6mediumDLA-749-1
php7.0source(unstable)7.0.11-1medium

Notes

PHP Bug: https://bugs.php.net/bug.php?id=73065
Fixed in 7.0.11, 5.6.26
https://github.com/php/php-src/commit/c4cca4c20e75359c9a13a1f9a36cb7b4e9601d29?w=1
The scope of this CVE also includes all of the "other four similar issues"
in the "[2016-09-12 06:44 UTC]" comment.

Search for package or bug name: Reporting problems