CVE-2016-7498

NameCVE-2016-7498
DescriptionOpenStack Compute (nova) 13.0.0 does not properly delete instances from compute nodes, which allows remote authenticated users to cause a denial of service (disk consumption) by deleting instances while in the resize state. NOTE: this vulnerability exists because of a CVE-2015-3280 regression.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
nova (PTS)stretch (security), stretch2:14.0.0-4+deb9u1fixed
buster2:18.1.0-6fixed
bullseye, sid2:22.0.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
novasourcewheezy(not affected)
novasourcejessie(not affected)
novasource(unstable)2:13.1.0-1

Notes

[jessie] - nova <not-affected> (Vulnerable code (re)introduced later)
[wheezy] - nova <not-affected> (Vulnerable code (re)introduced later)
Relates to OSSA-2015-017 (CVE-2015-3280) which was previously fixed
and then reintroduced with 13.0.0 and refixed in 13.1.0.

Search for package or bug name: Reporting problems