CVE-2016-7568

NameCVE-2016-7568
DescriptionInteger overflow in the gdImageWebpCtx function in gd_webp.c in the GD Graphics Library (aka libgd) through 2.2.3, as used in PHP through 7.0.11, allows remote attackers to cause a denial of service (heap-based buffer overflow) or possibly have unspecified other impact via crafted imagewebp and imagedestroy calls.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3693-1
NVD severityhigh (attack range: remote)
Debian Bugs839659

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgd2 (PTS)wheezy2.0.36~rc1~dfsg-6.1+deb7u2fixed
wheezy (security)2.0.36~rc1~dfsg-6.1+deb7u10fixed
jessie (security), jessie2.1.0-5+deb8u11fixed
stretch (security), stretch2.2.4-2+deb9u2fixed
buster, sid2.2.5-4fixed
php5 (PTS)wheezy5.4.45-0+deb7u2vulnerable
wheezy (security)5.4.45-0+deb7u11vulnerable
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed
php7.0 (PTS)stretch7.0.19-1fixed
buster, sid7.0.26-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgd2source(unstable)2.2.3-87-gd0fec80-1high839659
libgd2sourcejessie2.1.0-5+deb8u7highDSA-3693-1
libgd2sourcewheezy(not affected)
php5source(unstable)(unfixed)unimportant
php5sourcejessie5.6.27+dfsg-0+deb8u1high
php7.0source(unstable)7.0.12-1unimportant

Notes

[wheezy] - libgd2 <not-affected> (Vulnerable code not present)
libgd bug: https://github.com/libgd/libgd/issues/308
Fixed by: https://github.com/libgd/libgd/commit/2806adfdc27a94d333199345394d7c302952b95f
PHP Bug: https://bugs.php.net/bug.php?id=73003
https://github.com/php/php-src/commit/c18263e0e0769faee96a5d0ee04b750c442783c6

Search for package or bug name: Reporting problems