CVE-2016-7797

NameCVE-2016-7797
DescriptionPacemaker before 1.1.15, when using pacemaker remote, might allow remote attackers to cause a denial of service (node disconnection) via an unauthenticated connection.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pacemaker (PTS)stretch1.1.16-1fixed
stretch (security)1.1.24-0+deb9u1fixed
buster, buster (security)2.0.1-5+deb10u1fixed
bullseye2.0.5-2fixed
bookworm2.1.1-2fixed
sid2.1.2-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pacemakersourcewheezy(not affected)
pacemakersource(unstable)1.1.15~rc3-1

Notes

[wheezy] - pacemaker <not-affected> (Vulnerable code introduced after 1.1.10)
http://bugs.clusterlabs.org/show_bug.cgi?id=5269
Fixed by: https://github.com/ClusterLabs/pacemaker/commit/5ec24a2642bd0854b884d1a9b51d12371373b410 (Pacemaker-1.1.15-rc1)
Vulnerable code introduced in: https://github.com/ClusterLabs/pacemaker/commit/87f40917feb5109f827d83765c924acbbd824379 (Pacemaker-1.1.12-rc1)

Search for package or bug name: Reporting problems