CVE-2016-7910

NameCVE-2016-7910
DescriptionUse-after-free vulnerability in the disk_seqf_stop function in block/genhd.c in the Linux kernel before 4.7.1 allows local users to gain privileges by leveraging the execution of a certain stop operation even if the corresponding start operation had failed.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-772-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)wheezy3.2.78-1vulnerable
wheezy (security)3.2.96-3fixed
jessie3.16.51-2fixed
jessie (security)3.16.51-3+deb8u1fixed
stretch4.9.65-3fixed
stretch (security)4.9.65-3+deb9u2fixed
buster4.14.7-1fixed
sid4.14.13-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.7.2-1high
linuxsourcejessie3.16.39-1high
linuxsourcewheezy3.2.84-1highDLA-772-1

Notes

Fixed by: https://git.kernel.org/linus/77da160530dd1dc94f6ae15a981f24e5f0021e84 (v4.8-rc1)

Search for package or bug name: Reporting problems