CVE-2016-7944

NameCVE-2016-7944
DescriptionInteger overflow in X.org libXfixes before 5.0.3 on 32-bit platforms might allow remote X servers to gain privileges via a length value of INT_MAX, which triggers the client to stop reading data and get out of sync.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-654-1
NVD severityhigh
Debian Bugs840442

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxfixes (PTS)buster, stretch1:5.0.3-1fixed
bookworm, sid, bullseye1:5.0.3-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxfixessourcewheezy1:5.0-4+deb7u2DLA-654-1
libxfixessourcejessie1:5.0.1-2+deb8u1
libxfixessource(unstable)1:5.0.3-1low840442

Notes

https://cgit.freedesktop.org/xorg/lib/libXfixes/commit/?id=61c1039ee23a2d1de712843bed3480654d7ef42e

Search for package or bug name: Reporting problems