CVE-2016-7949

NameCVE-2016-7949
DescriptionMultiple buffer overflows in the (1) XvQueryAdaptors and (2) XvQueryEncodings functions in X.org libXrender before 0.9.10 allow remote X servers to trigger out-of-bounds write operations via vectors involving length fields.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-664-1
NVD severityhigh
Debian Bugs840443

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxrender (PTS)jessie1:0.9.8-1vulnerable
bullseye, sid, buster, stretch1:0.9.10-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxrendersource(unstable)1:0.9.10-1low840443
libxrendersourcewheezy1:0.9.7-1+deb7u3DLA-664-1

Notes

[jessie] - libxrender <no-dsa> (Minor issue, will be fixed in a point release)
https://cgit.freedesktop.org/xorg/lib/libXrender/commit/?id=9362c7ddd1af3b168953d0737877bc52d79c94f4

Search for package or bug name: Reporting problems