CVE-2016-7977

NameCVE-2016-7977
DescriptionGhostscript before 9.21 might allow remote attackers to bypass the SAFER mode protection mechanism and consequently read arbitrary files via the use of the .libfile operator in a crafted postscript document.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-674-1, DSA-3691-1
NVD severitymedium
Debian Bugs839841

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)stretch9.26a~dfsg-0+deb9u6fixed
stretch (security)9.26a~dfsg-0+deb9u7fixed
buster, buster (security)9.27~dfsg-2+deb10u4fixed
bullseye (security), bullseye9.53.3~dfsg-7+deb11u1fixed
bookworm, sid9.54.0~dfsg-5fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsourcewheezy9.05~dfsg-6.3+deb7u3DLA-674-1
ghostscriptsourcejessie9.06~dfsg-2+deb8u3DSA-3691-1
ghostscriptsource(unstable)9.19~dfsg-3.1high839841

Notes

Upstream bug: http://bugs.ghostscript.com/show_bug.cgi?id=697169
Reproducer: https://www.openwall.com/lists/oss-security/2016/09/29/28
Patch: https://git.ghostscript.com/?p=ghostpdl.git;h=8abd22010eb4db0fb1b10e430d5f5d83e015ef70
https://www.openwall.com/lists/oss-security/2016/10/05/7

Search for package or bug name: Reporting problems