CVE-2016-7979

NameCVE-2016-7979
DescriptionGhostscript before 9.21 might allow remote attackers to bypass the SAFER mode protection mechanism and consequently execute arbitrary code by leveraging type confusion in .initialize_dsc_parser.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-674-1, DSA-3691-1
NVD severityhigh (attack range: remote)
Debian Bugs839846

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)wheezy9.05~dfsg-6.3+deb7u2vulnerable
wheezy (security)9.05~dfsg-6.3+deb7u7fixed
jessie9.06~dfsg-2+deb8u5fixed
jessie (security)9.06~dfsg-2+deb8u6fixed
stretch (security), stretch9.20~dfsg-3.2+deb9u1fixed
buster, sid9.22~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsource(unstable)9.19~dfsg-3.1high839846
ghostscriptsourcejessie9.06~dfsg-2+deb8u3highDSA-3691-1
ghostscriptsourcewheezy9.05~dfsg-6.3+deb7u3highDLA-674-1

Notes

Upstream bug: http://bugs.ghostscript.com/show_bug.cgi?id=697190
Reproducer: http://bugs.ghostscript.com/show_bug.cgi?id=697190#c0
Patch: http://git.ghostscript.com/?p=ghostpdl.git;h=875a0095f37626a721c7ff57d606a0f95af03913
http://www.openwall.com/lists/oss-security/2016/10/05/7
http://www.openwall.com/lists/oss-security/2016/10/05/19

Search for package or bug name: Reporting problems