CVE-2016-7980

NameCVE-2016-7980
DescriptionCross-site request forgery (CSRF) vulnerability in ecrire/exec/valider_xml.php in SPIP 3.1.2 and earlier allows remote attackers to hijack the authentication of administrators for requests that execute the XML validator on a local file via a crafted valider_xml request. NOTE: this issue can be combined with CVE-2016-7998 to execute arbitrary PHP code.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-695-1
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
spip (PTS)stretch3.1.4-4~deb9u3fixed
stretch (security)3.1.4-4~deb9u4+deb9u1fixed
buster, buster (security)3.2.4-1+deb10u4fixed
bookworm, bullseye, sid3.2.11-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
spipsourcewheezy2.1.17-1+deb7u6DLA-695-1
spipsourcejessie3.0.17-2+deb8u3
spipsource(unstable)3.1.3-1

Notes

http://seclists.org/fulldisclosure/2016/Oct/67
https://core.spip.net/projects/spip/repository/revisions/23200 (master)
https://core.spip.net/projects/spip/repository/revisions/23201 (3.1)
https://core.spip.net/projects/spip/repository/revisions/23202 (3.0)
reproducible in Wheezy (2.1.17-1+deb7u5) and Jessie (3.0.17-2+deb8u2)

Search for package or bug name: Reporting problems