CVE-2016-7996

NameCVE-2016-7996
DescriptionHeap-based buffer overflow in the WPG format reader in GraphicsMagick 1.3.25 and earlier allows remote attackers to have unspecified impact via a colormap with a large number of entries.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-683-1, DSA-3746-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)wheezy1.3.16-1.1vulnerable
wheezy (security)1.3.16-1.1+deb7u10fixed
jessie1.3.20-3+deb8u1vulnerable
jessie (security)1.3.20-3+deb8u2fixed
stretch1.3.25-8fixed
buster, sid1.3.26-15fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
graphicsmagicksource(unstable)1.3.21-2high
graphicsmagicksourcejessie1.3.20-3+deb8u2highDSA-3746-1
graphicsmagicksourcewheezy1.3.16-1.1+deb7u5highDLA-683-1

Notes

The patch addressing CVE-2016-7996 applied is in 1.3.25-4, but in
the experimental upload 1.3.20-4 and later uploaded to unstable as
1.3.21-2 the build is done with --with-quantum-depth=16 switching
away from the default with QuantumDepth=8
patch for this and CVE-2016-7997 at: http://openwall.com/lists/oss-security/2016/10/07/4

Search for package or bug name: Reporting problems