DescriptionHeap-based buffer overflow in the WPG format reader in GraphicsMagick 1.3.25 and earlier allows remote attackers to have unspecified impact via a colormap with a large number of entries.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-683-1, DSA-3746-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
graphicsmagick (PTS)jessie1.3.20-3+deb8u2fixed
jessie (security)1.3.20-3+deb8u7fixed
stretch (security), stretch1.3.30+hg15796-1~deb9u2fixed
bullseye, sid1.4+really1.3.33+hg16117-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs


The patch addressing CVE-2016-7996 applied is in 1.3.25-4, but in
the experimental upload 1.3.20-4 and later uploaded to unstable as
1.3.21-2 the build is done with --with-quantum-depth=16 switching
away from the default with QuantumDepth=8
patch for this and CVE-2016-7997 at:

Search for package or bug name: Reporting problems