CVE-2016-8602

NameCVE-2016-8602
DescriptionThe .sethalftone5 function in psi/zht2.c in Ghostscript before 9.21 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted Postscript document that calls .sethalftone5 with an empty operand stack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-674-1, DSA-3691-1
NVD severitymedium (attack range: remote)
Debian Bugs840451

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ghostscript (PTS)wheezy9.05~dfsg-6.3+deb7u2vulnerable
wheezy (security)9.05~dfsg-6.3+deb7u7fixed
jessie9.06~dfsg-2+deb8u5fixed
jessie (security)9.06~dfsg-2+deb8u6fixed
stretch (security), stretch9.20~dfsg-3.2+deb9u1fixed
buster, sid9.22~dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ghostscriptsource(unstable)9.19~dfsg-3.1medium840451
ghostscriptsourcejessie9.06~dfsg-2+deb8u3mediumDSA-3691-1
ghostscriptsourcewheezy9.05~dfsg-6.3+deb7u3mediumDLA-674-1

Notes

http://bugs.ghostscript.com/show_bug.cgi?id=697203
http://git.ghostscript.com/?p=ghostpdl.git;a=commit;h=f5c7555c30393e64ec1f5ab0dfae5b55b3b3fc78

Search for package or bug name: Reporting problems