CVE-2016-8606

NameCVE-2016-8606
DescriptionThe REPL server (--listen) in GNU Guile 2.0.12 allows an attacker to execute arbitrary code via an HTTP inter-protocol attack.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-666-1
NVD severityhigh (attack range: remote)
Debian Bugs840555

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
guile-1.8 (PTS)wheezy1.8.8+1-8fixed
jessie1.8.8+1-10fixed
guile-2.0 (PTS)wheezy2.0.5+1-3vulnerable
wheezy (security)2.0.5+1-3+deb7u2fixed
jessie2.0.11+1-9+deb8u1fixed
buster, sid, stretch2.0.13+1-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
guile-1.8source(unstable)(not affected)
guile-2.0source(unstable)2.0.13+1-1low840555
guile-2.0sourcejessie2.0.11+1-9+deb8u1high
guile-2.0sourcewheezy2.0.5+1-3+deb7u1highDLA-666-1

Notes

- guile-1.8 <not-affected> (repl server introduced in 2.0)
Patch: http://git.savannah.gnu.org/cgit/guile.git/commit/?h=stable-2.0&id=08c021916dbd3a235a9f9cc33df4c418c0724e03

Search for package or bug name: Reporting problems