CVE-2016-8616

NameCVE-2016-8616
DescriptionA flaw was found in curl before version 7.51.0 When re-using a connection, curl was doing case insensitive comparisons of user name and password with the existing connections. This means that if an unused connection with proper credentials exists for a protocol that has connection-scoped credentials, an attacker can cause that connection to be reused if s/he knows the case-insensitive version of the correct password.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-711-1, DSA-3705-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)jessie7.38.0-4+deb8u11fixed
jessie (security)7.38.0-4+deb8u12fixed
stretch7.52.1-5+deb9u6fixed
stretch (security)7.52.1-5+deb9u7fixed
buster, sid7.61.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsource(unstable)7.51.0-1medium
curlsourcejessie7.38.0-4+deb8u5mediumDSA-3705-1
curlsourcewheezy7.26.0-1+wheezy17mediumDLA-711-1

Notes

https://github.com/curl/curl/commit/b3ee26c5df75d97f6895e6ec4538894ebaf76e48
https://curl.haxx.se/docs/adv_20161102B.html
https://curl.haxx.se/CVE-2016-8616.patch

Search for package or bug name: Reporting problems