CVE-2016-8620

NameCVE-2016-8620
DescriptionThe 'globbing' feature in curl before version 7.51.0 has a flaw that leads to integer overflow and out-of-bounds read via user controlled input.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3705-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)stretch7.52.1-5+deb9u10fixed
stretch (security)7.52.1-5+deb9u15fixed
buster, buster (security)7.64.0-4+deb10u2fixed
bookworm, sid, bullseye7.74.0-1.3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsourcewheezy(not affected)
curlsourcejessie7.38.0-4+deb8u5DSA-3705-1
curlsource(unstable)7.51.0-1

Notes

[wheezy] - curl <not-affected> (Vulnerable code introduced in 7.34.0)
https://github.com/curl/curl/commit/fbb5f1aa0326d485d5a7ac643b48481897ca667f
https://curl.haxx.se/docs/adv_20161102F.html
https://curl.haxx.se/CVE-2016-8620.patch

Search for package or bug name: Reporting problems