CVE-2016-8621

NameCVE-2016-8621
DescriptionThe `curl_getdate` function in curl before version 7.51.0 is vulnerable to an out of bounds read if it receives an input with one digit short.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub advisories/code/issues, web search, more)
ReferencesDLA-711-1, DSA-3705-1

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)buster7.64.0-4+deb10u2fixed
buster (security)7.64.0-4+deb10u3fixed
bullseye7.74.0-1.3+deb11u3fixed
bullseye (security)7.74.0-1.3+deb11u2fixed
bookworm, sid7.86.0-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsourcewheezy7.26.0-1+wheezy17DLA-711-1
curlsourcejessie7.38.0-4+deb8u5DSA-3705-1
curlsource(unstable)7.51.0-1

Notes

https://github.com/curl/curl/commit/96a80b5a262fb6dd2ddcea7987296f3b9a405618
https://curl.haxx.se/docs/adv_20161102G.html
https://curl.haxx.se/CVE-2016-8621.patch

Search for package or bug name: Reporting problems