CVE-2016-8633

NameCVE-2016-8633
Descriptiondrivers/firewire/net.c in the Linux kernel before 4.8.7, in certain unusual hardware configurations, allows remote attackers to execute arbitrary code via crafted fragmented packets.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-772-1
NVD severitymedium (attack range: local)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)wheezy3.2.78-1vulnerable
wheezy (security)3.2.96-3fixed
jessie3.16.51-2fixed
jessie (security)3.16.51-3+deb8u1fixed
stretch4.9.65-3fixed
stretch (security)4.9.65-3+deb9u2fixed
buster4.14.7-1fixed
sid4.14.13-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsource(unstable)4.8.7-1medium
linuxsourcejessie3.16.39-1medium
linuxsourcewheezy3.2.84-1mediumDLA-772-1

Notes

https://git.kernel.org/linus/667121ace9dbafb368618dbabcf07901c962ddac
https://eyalitkin.wordpress.com/2016/11/06/cve-publication-cve-2016-8633/

Search for package or bug name: Reporting problems