CVE-2016-8650

NameCVE-2016-8650
DescriptionThe mpi_powm function in lib/mpi/mpi-pow.c in the Linux kernel through 4.8.11 does not ensure that memory is allocated for limb data, which allows local users to cause a denial of service (stack memory corruption and panic) via an add_key system call for an RSA key with a zero exponent.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
linux (PTS)stretch4.9.228-1fixed
stretch (security)4.9.290-1fixed
buster4.19.208-1fixed
buster (security)4.19.194-3fixed
bullseye5.10.84-1fixed
bullseye (security)5.10.46-5fixed
bookworm5.15.5-2fixed
sid5.15.15-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
linuxsourcewheezy(not affected)
linuxsourcejessie3.16.39-1
linuxsource(unstable)4.8.11-1

Notes

[wheezy] - linux <not-affected> (Vulnerable code introduced later)
http://seclists.org/fulldisclosure/2016/Nov/76
Proposed fix: https://lkml.org/lkml/2016/11/23/477
Fixed by: https://git.kernel.org/linus/f5527fffff3f002b0a6b376163613b82f69de073
Introduced by https://git.kernel.org/linus/cdec9cb5167ab1113ba9c58e395f664d9d3f9acb (v3.3-rc1)
https://bugzilla.redhat.com/show_bug.cgi?id=1343162 (not yet opened)

Search for package or bug name: Reporting problems