CVE-2016-8670

NameCVE-2016-8670
DescriptionInteger signedness error in the dynamicGetbuf function in gd_io_dp.c in the GD Graphics Library (aka libgd) through 2.2.3, as used in PHP before 5.6.28 and 7.x before 7.0.13, allows remote attackers to cause a denial of service (stack-based buffer overflow) or possibly have unspecified other impact via a crafted imagecreatefromstring call.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-665-1, DSA-3693-1
NVD severityhigh (attack range: remote)
Debian Bugs840805

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgd2 (PTS)wheezy2.0.36~rc1~dfsg-6.1+deb7u2vulnerable
wheezy (security)2.0.36~rc1~dfsg-6.1+deb7u10fixed
jessie2.1.0-5+deb8u9fixed
jessie (security)2.1.0-5+deb8u11fixed
stretch (security), stretch2.2.4-2+deb9u2fixed
buster, sid2.2.5-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgd2source(unstable)2.2.3-87-gd0fec80-1high840805
libgd2sourcejessie2.1.0-5+deb8u7highDSA-3693-1
libgd2sourcewheezy2.0.36~rc1~dfsg-6.1+deb7u6highDLA-665-1

Notes

PHP Bug: https://bugs.php.net/bug.php?id=73280
https://github.com/libgd/libgd/commit/53110871935244816bbb9d131da0bccff734bfe9
http://www.openwall.com/lists/oss-security/2016/10/15/1

Search for package or bug name: Reporting problems