CVE-2016-8734

NameCVE-2016-8734
DescriptionSubversion's mod_dontdothat module and HTTP clients 1.4.0 through 1.8.16, and 1.9.0 through 1.9.4 are vulnerable to a denial-of-service attack caused by exponential XML entity expansion. The attack can cause the targeted process to consume an excessive amount of CPU resources or memory.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
subversion (PTS)wheezy1.6.17dfsg-4+deb7u10vulnerable
wheezy (security)1.6.17dfsg-4+deb7u12vulnerable
jessie1.8.10-6+deb8u4vulnerable
jessie (security)1.8.10-6+deb8u5fixed
stretch (security), stretch1.9.5-1+deb9u1fixed
buster, sid1.9.7-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
subversionsource(unstable)1.9.5-1low
subversionsourcejessie1.8.10-6+deb8u5

Notes

[wheezy] - subversion <no-dsa> (Minor issue, binary packages not affected since built against Neon as HTTP library)
Above wheezy entry workarounded; binary packages not affected (since in wheezy build against Neon as HTTP
library), though source is. (unimporant) for individual lines is not supported, thus workaround by marking
as no-dsa.
https://subversion.apache.org/security/CVE-2016-8734-advisory.txt

Search for package or bug name: Reporting problems