CVE-2016-8735

NameCVE-2016-8735
DescriptionRemote code execution is possible with Apache Tomcat before 6.0.48, 7.x before 7.0.73, 8.x before 8.0.39, 8.5.x before 8.5.7, and 9.x before 9.0.0.M12 if JmxRemoteLifecycleListener is used and an attacker can reach JMX ports. The issue exists because this listener wasn't updated for consistency with the CVE-2016-3427 Oracle patch that affected credential types.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-728-1, DLA-729-1, DSA-3738-1, DSA-3739-1
NVD severityhigh

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
tomcat7 (PTS)stretch7.0.75-1fixed
tomcat8 (PTS)stretch8.5.54-0+deb9u1fixed
stretch (security)8.5.54-0+deb9u3fixed
tomcat9 (PTS)buster, buster (security)9.0.31-1~deb10u2fixed
bullseye, sid9.0.38-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
tomcat6sourcewheezy6.0.45+dfsg-1~deb7u3DLA-728-1
tomcat6source(unstable)6.0.41-3low
tomcat7sourcewheezy7.0.28-4+deb7u7DLA-729-1
tomcat7sourcejessie7.0.56-3+deb8u6DSA-3738-1
tomcat7source(unstable)7.0.72-3
tomcat8sourcejessie8.0.14-1+deb8u5DSA-3739-1
tomcat8source(unstable)8.0.39-1
tomcat9source(unstable)(not affected)

Notes

- tomcat9 <not-affected> (Fixed before initial upload to Debian)
Since 7.0.72-3, src:tomcat7 only builds the Servlet API
Since 6.0.41-3, src:tomcat6 only builds a servlet and docs in Jessie
Fixed by: http://svn.apache.org/r1767656 (8.0.x)
Fixed by: http://svn.apache.org/r1767676 (7.0.x)
Fixed by: http://svn.apache.org/r1767684 (6.0.x)

Search for package or bug name: Reporting problems