CVE-2016-8743

NameCVE-2016-8743
DescriptionApache HTTP Server, in all releases prior to 2.2.32 and 2.4.25, was liberal in the whitespace accepted from requests and sent in response lines and headers. Accepting these different behaviors represented a security concern when httpd participates in any chain of proxies or interacts with back-end application servers, either through mod_proxy or using conventional CGI mechanisms, and may result in request smuggling, response splitting and cache pollution.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-841-1, DLA-841-2, DSA-3796-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
apache2 (PTS)jessie (security), jessie2.4.10-10+deb8u12fixed
stretch2.4.25-3+deb9u5fixed
stretch (security)2.4.25-3+deb9u4fixed
buster, sid2.4.34-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
apache2source(unstable)2.4.25-1medium
apache2sourcejessie2.4.10-10+deb8u8mediumDSA-3796-1
apache2sourcewheezy2.2.22-13+deb7u11mediumDLA-841-2

Notes

https://lists.apache.org/thread.html/139862b41c0dfd5e6e00ad89c00119f9faf0dd41a2f927da9c9a4076@%3Cannounce.httpd.apache.org%3E
https://httpd.apache.org/security/vulnerabilities_24.html
The fix is not fully backwards compatible so upstream have
created a new option to control this behaviour. This means that
if this is fixed the security advisory need to mention this.
The fix is invasive and should require some extra testing before reaching
stable and old-stable.
Affects: 2.2.0 to 2.4.23.
Fixed in 2.4.25.
For 2.2 preparation is done in http://svn.apache.org/viewvc/httpd/httpd/branches/2.2.x-merge-http-strict/

Search for package or bug name: Reporting problems