CVE-2016-8864

NameCVE-2016-8864
Descriptionnamed in ISC BIND 9.x before 9.9.9-P4, 9.10.x before 9.10.4-P4, and 9.11.x before 9.11.0-P1 allows remote attackers to cause a denial of service (assertion failure and daemon exit) via a DNAME record in the answer section of a response to a recursive query, related to db.c and resolver.c.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-696-1, DSA-3703-1
NVD severitymedium (attack range: remote)
Debian Bugs842858

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
bind9 (PTS)wheezy1:9.8.4.dfsg.P1-6+nmu2+deb7u10vulnerable
wheezy (security)1:9.8.4.dfsg.P1-6+nmu2+deb7u18fixed
jessie1:9.9.5.dfsg-9+deb8u12fixed
jessie (security)1:9.9.5.dfsg-9+deb8u13fixed
stretch1:9.10.3.dfsg.P4-12.3+deb9u3fixed
stretch (security)1:9.10.3.dfsg.P4-12.3+deb9u2fixed
buster1:9.10.3.dfsg.P4-12.6fixed
sid1:9.10.6+dfsg-2fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
bind9source(unstable)1:9.10.3.dfsg.P4-11medium842858
bind9sourceexperimental1:9.10.4-P5-1medium
bind9sourcejessie1:9.9.5.dfsg-9+deb8u8mediumDSA-3703-1
bind9sourcewheezy1:9.8.4.dfsg.P1-6+nmu2+deb7u13mediumDLA-696-1

Notes

https://kb.isc.org/article/AA-01434
upstream fix https://source.isc.org/cgi-bin/gitweb.cgi?p=bind9.git;a=commitdiff;h=8bd0c12d53bea6f299e92d20ee0a23b16a7f65bc

Search for package or bug name: Reporting problems