CVE-2016-9085

NameCVE-2016-9085
DescriptionMultiple integer overflows in libwebp allows attackers to have unspecified impact via unknown vectors.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severityhigh (attack range: remote)
Debian Bugs842714

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libwebp (PTS)wheezy0.1.3-3+nmu1fixed
jessie0.4.1-1.2vulnerable
stretch0.5.2-1vulnerable
buster, sid0.6.0-4vulnerable

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libwebpsource(unstable)(unfixed)unimportant842714
libwebpsourcewheezy(not affected)

Notes

[wheezy] - libwebp <not-affected> (vulnerable code not present)
https://chromium.googlesource.com/webm/libwebp/+/e2affacc35f1df6cc3b1a9fa0ceff5ce2d0cce83
Report: https://bugs.chromium.org/p/webp/issues/detail?id=314 (private)
For libwebp only in examples, but other projects seem to use the gifdec.c
Origin of the file seems to be from libav
0.5.1-3 claims the upload fixed CVE-2016-8888 and CVE-2016-9085 but the taken patches
look different, needs further investigation before marking as fixed

Search for package or bug name: Reporting problems