CVE-2016-9104

NameCVE-2016-9104
DescriptionMultiple integer overflows in the (1) v9fs_xattr_read and (2) v9fs_xattr_write functions in hw/9pfs/9p.c in QEMU (aka Quick Emulator) allow local guest OS administrators to cause a denial of service (QEMU process crash) via a crafted offset, which triggers an out-of-bounds access.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-689-1, DLA-698-1
NVD severitylow (attack range: local)
Debian Bugs842463

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)wheezy1.1.2+dfsg-6a+deb7u12vulnerable
wheezy (security)1.1.2+dfsg-6+deb7u23fixed
jessie, jessie (security)1:2.1+dfsg-12+deb8u6vulnerable
stretch1:2.8+dfsg-6fixed
stretch (security)1:2.8+dfsg-6+deb9u2fixed
buster, sid1:2.8+dfsg-7fixed
qemu-kvm (PTS)wheezy1.1.2+dfsg-6+deb7u12vulnerable
wheezy (security)1.1.2+dfsg-6+deb7u23fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)1:2.8+dfsg-1low842463
qemusourcewheezy1.1.2+dfsg-6+deb7u18lowDLA-698-1
qemu-kvmsource(unstable)(unfixed)low
qemu-kvmsourcewheezy1.1.2+dfsg-6+deb7u18lowDLA-689-1

Notes

[jessie] - qemu <no-dsa> (Minor issue)
https://lists.gnu.org/archive/html/qemu-devel/2016-10/msg02942.html
http://www.openwall.com/lists/oss-security/2016/10/28/2

Search for package or bug name: Reporting problems