CVE-2016-9105

NameCVE-2016-9105
DescriptionMemory leak in the v9fs_link function in hw/9pfs/9p.c in QEMU (aka Quick Emulator) allows local guest OS administrators to cause a denial of service (memory consumption) via vectors involving a reference to the source fid object.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1599-1, DLA-689-1, DLA-698-1
NVD severitylow
Debian Bugs842463

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie1:2.1+dfsg-12+deb8u6vulnerable
jessie (security)1:2.1+dfsg-12+deb8u13fixed
stretch1:2.8+dfsg-6+deb9u8fixed
stretch (security)1:2.8+dfsg-6+deb9u9fixed
buster1:3.1+dfsg-8+deb10u3fixed
buster (security)1:3.1+dfsg-8+deb10u4fixed
bullseye, sid1:4.2-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)1:2.8+dfsg-1842463
qemusourcejessie1:2.1+dfsg-12+deb8u8DLA-1599-1
qemusourcewheezy1.1.2+dfsg-6+deb7u18DLA-698-1
qemu-kvmsource(unstable)(unfixed)
qemu-kvmsourcewheezy1.1.2+dfsg-6+deb7u18DLA-689-1

Notes

https://lists.gnu.org/archive/html/qemu-devel/2016-10/msg02608.html
http://www.openwall.com/lists/oss-security/2016/10/28/3
http://git.qemu.org/?p=qemu.git;a=commit;h=4c1586787ff43c9acd18a56c12d720e3e6be9f7c

Search for package or bug name: Reporting problems