CVE-2016-9112

NameCVE-2016-9112
DescriptionFloating Point Exception (aka FPE or divide by zero) in opj_pi_next_cprl function in openjp2/pi.c:523 in OpenJPEG 2.1.2.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1851-1
NVD severitymedium (attack range: remote)
Debian Bugs844551

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
openjpeg2 (PTS)jessie2.1.0-2+deb8u3vulnerable
jessie (security)2.1.0-2+deb8u8fixed
stretch (security), stretch2.1.2-1.1+deb9u3vulnerable
buster2.3.0-2fixed
bullseye, sid2.3.1-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
openjpeg2source(unstable)2.1.2-1.2medium844551
openjpeg2sourcejessie2.1.0-2+deb8u7mediumDLA-1851-1

Notes

[stretch] - openjpeg2 <no-dsa> (Minor issue)
https://github.com/uclouvain/openjpeg/commit/d27ccf01c68a31ad62b33d2dc1ba2bb1eeaafe7b
https://github.com/uclouvain/openjpeg/issues/855

Search for package or bug name: Reporting problems