CVE-2016-9138

NameCVE-2016-9138
DescriptionPHP through 5.6.27 and 7.x through 7.0.12 mishandles property modification during __wakeup processing, which allows remote attackers to cause a denial of service or possibly have unspecified other impact via crafted serialized data, as demonstrated by Exception::__toString with DateInterval::__wakeup.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDSA-3732-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
php5 (PTS)wheezy5.4.45-0+deb7u2fixed
wheezy (security)5.4.45-0+deb7u11fixed
jessie (security), jessie5.6.30+dfsg-0+deb8u1fixed
php7.0 (PTS)stretch7.0.19-1fixed
buster, sid7.0.26-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
php5source(unstable)(unfixed)high
php5sourcejessie5.6.28+dfsg-0+deb8u1highDSA-3732-1
php5sourcewheezy(not affected)
php7.0source(unstable)7.0.12-1high

Notes

[wheezy] - php5 <not-affected> (Vulnerable code not present in version 5.4.45)
PHP Bug: https://bugs.php.net/bug.php?id=73147
http://www.openwall.com/lists/oss-security/2016/11/01/7

Search for package or bug name: Reporting problems