CVE-2016-9189

NameCVE-2016-9189
DescriptionPillow before 3.3.2 allows context-dependent attackers to obtain sensitive information by using the "crafted image file" approach, related to an "Integer Overflow" issue affecting the Image.core.map_buffer in map.c component.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-705-1, DSA-3710-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
pillow (PTS)jessie (security), jessie2.6.1-2+deb8u3fixed
stretch4.0.0-4fixed
buster4.2.1-1fixed
sid4.3.0-1fixed
python-imaging (PTS)wheezy1.1.7-4+deb7u2vulnerable
wheezy (security)1.1.7-4+deb7u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
pillowsource(unstable)3.4.2-1medium
pillowsourcejessie2.6.1-2+deb8u3mediumDSA-3710-1
python-imagingsource(unstable)(unfixed)medium
python-imagingsourcewheezy1.1.7-4+deb7u3mediumDLA-705-1

Notes

https://github.com/python-pillow/Pillow/issues/2105
https://github.com/python-pillow/Pillow/pull/2146/commits/c50ebe6459a131a1ea8ca531f10da616d3ceaa0f

Search for package or bug name: Reporting problems