CVE-2016-9298

NameCVE-2016-9298
DescriptionHeap overflow in the WaveletDenoiseImage function in MagickCore/fx.c in ImageMagick before 6.9.6-4 and 7.x before 7.0.3-6 allows remote attackers to cause a denial of service (crash) via a crafted image.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)
Debian Bugs844211

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
imagemagick (PTS)wheezy8:6.7.7.10-5+deb7u4fixed
wheezy (security)8:6.7.7.10-5+deb7u22fixed
jessie8:6.8.9.9-5+deb8u11fixed
jessie (security)8:6.8.9.9-5+deb8u12fixed
stretch8:6.9.7.4+dfsg-11+deb9u3fixed
stretch (security)8:6.9.7.4+dfsg-11+deb9u4fixed
buster8:6.9.9.34+dfsg-3fixed
sid8:6.9.9.39+dfsg-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
imagemagicksource(unstable)8:6.9.6.5+dfsg-1medium844211
imagemagicksourcejessie(not affected)
imagemagicksourcewheezy(not affected)

Notes

[jessie] - imagemagick <not-affected> (Vulnerable code not present)
[wheezy] - imagemagick <not-affected> (Vulnerable code not present)
https://github.com/ImageMagick/ImageMagick/issues/296
http://www.openwall.com/lists/oss-security/2016/11/13/1

Search for package or bug name: Reporting problems