CVE-2016-9317

NameCVE-2016-9317
DescriptionThe gdImageCreate function in the GD Graphics Library (aka libgd) before 2.2.4 allows remote attackers to cause a denial of service (system hang) via an oversized image.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SuSE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-804-1, DSA-3777-1
NVD severityhigh (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libgd2 (PTS)wheezy2.0.36~rc1~dfsg-6.1+deb7u2vulnerable
wheezy (security)2.0.36~rc1~dfsg-6.1+deb7u10fixed
jessie2.1.0-5+deb8u9fixed
jessie (security)2.1.0-5+deb8u11fixed
stretch (security), stretch2.2.4-2+deb9u2fixed
buster, sid2.2.5-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libgd2source(unstable)2.2.4-1high
libgd2sourcejessie2.1.0-5+deb8u9highDSA-3777-1
libgd2sourcewheezy2.0.36~rc1~dfsg-6.1+deb7u8highDLA-804-1

Notes

https://github.com/libgd/libgd/commit/6944ea10cb730d5071620439c6c2e823e6caeff1
https://github.com/libgd/libgd/issues/340

Search for package or bug name: Reporting problems