CVE-2016-9586

NameCVE-2016-9586
Descriptioncurl before version 7.52.0 is vulnerable to a buffer overflow when doing a large floating point output in libcurl's implementation of the printf() functions. If there are any application that accepts a format string from the outside without necessary input filtering, it could allow remote attacks.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1568-1, DLA-767-1
NVD severitymedium
Debian Bugs848958

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
curl (PTS)stretch7.52.1-5+deb9u10fixed
stretch (security)7.52.1-5+deb9u12fixed
buster, buster (security)7.64.0-4+deb10u1fixed
bullseye, sid7.72.0-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
curlsourcewheezy7.26.0-1+wheezy18DLA-767-1
curlsourcejessie7.38.0-4+deb8u13DLA-1568-1
curlsource(unstable)7.52.1-1848958

Notes

https://curl.haxx.se/docs/adv_20161221A.html
Fixed by: https://github.com/curl/curl/commit/3ab3c16db6a5674f53cf23d56512a405fde0b2c9
There are no known vulnerable applications but as this is a
library it should be fixed as we do not know the full impact.

Search for package or bug name: Reporting problems