CVE-2016-9591

NameCVE-2016-9591
DescriptionJasPer before version 2.0.12 is vulnerable to a use-after-free in the way it decodes certain JPEG 2000 image files resulting in a crash on the application using JasPer.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-920-1, DSA-3827-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
jasper (PTS)jessie (security), jessie1.900.1-debian1-2.4+deb8u3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
jaspersource(unstable)(unfixed)medium
jaspersourcejessie1.900.1-debian1-2.4+deb8u3mediumDSA-3827-1
jaspersourcewheezy1.900.1-13+deb7u6mediumDLA-920-1

Notes

https://github.com/mdadams/jasper/issues/105
Fixed by: https://github.com/mdadams/jasper/commit/03fe49ab96bf65fea784cdc256507ea88267fc7c

Search for package or bug name: Reporting problems