CVE-2016-9596

NameCVE-2016-9596
Descriptionlibxml2, as used in Red Hat JBoss Core Services and when in recovery mode, allows context-dependent attackers to cause a denial of service (stack consumption) via a crafted XML document. NOTE: this vulnerability exists because of an incorrect fix for CVE-2016-3627.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
libxml2 (PTS)jessie2.9.1+dfsg1-5+deb8u6fixed
jessie (security)2.9.1+dfsg1-5+deb8u8fixed
stretch (security), stretch2.9.4+dfsg1-2.2+deb9u2fixed
buster2.9.4+dfsg1-7fixed
bullseye2.9.4+dfsg1-8fixed
sid2.9.10+dfsg-4fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
libxml2source(unstable)(not affected)

Notes

- libxml2 <not-affected> (Red Hat specific security regressions)

Search for package or bug name: Reporting problems