CVE-2016-9602

NameCVE-2016-9602
DescriptionQemu before version 2.9 is vulnerable to an improper link following when built with the VirtFS. A privileged user inside guest could use this flaw to access host file system beyond the shared folder and potentially escalating their privileges on a host.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-1035-1, DLA-965-1
NVD severityhigh (attack range: remote)
Debian Bugs853006

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
qemu (PTS)jessie (security), jessie1:2.1+dfsg-12+deb8u6vulnerable
stretch (security), stretch1:2.8+dfsg-6+deb9u4fixed
buster, sid1:2.12+dfsg-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
qemusource(unstable)1:2.8+dfsg-3high853006
qemusourcewheezy1.1.2+dfsg-6+deb7u22highDLA-1035-1
qemu-kvmsource(unstable)(unfixed)high
qemu-kvmsourcewheezy1.1.2+dfsg-6+deb7u22highDLA-965-1

Notes

[jessie] - qemu <no-dsa> (Minor issue)
https://bugzilla.redhat.com/show_bug.cgi?id=1413929
The original proposed patch does not fix the issue, cf.
http://www.openwall.com/lists/oss-security/2017/01/17/14
Upstream patchset: https://lists.gnu.org/archive/html/qemu-devel/2017-01/msg06225.html
https://bugs.chromium.org/p/project-zero/issues/detail?id=1035
If fixing this issue for older suites, then make sure not to open the
CVE-2017-7471 vulnerability and apply as well 9c6b899f7a46893ab3b671e341a2234e9c0c060e
See further details in the CVE-2017-7471 tracker entry.

Search for package or bug name: Reporting problems