CVE-2016-9606

NameCVE-2016-9606
DescriptionJBoss RESTEasy before version 3.1.2 could be forced into parsing a request with YamlProvider, resulting in unmarshalling of potentially untrusted data which could allow an attacker to execute arbitrary code with RESTEasy application permissions.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
Debian Bugs851430

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
resteasy (PTS)sid3.6.2-2fixed
resteasy3.0 (PTS)buster3.0.26-1fixed
bullseye3.0.26-2fixed
bookworm, sid3.0.26-3fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
resteasysource(unstable)3.1.4-1851430
resteasy3.0source(unstable)3.0.26-1

Notes

[jessie] - resteasy <no-dsa> (Minor issue)
See CVE-2018-1051 to address original incomplete fix for CVE-2016-9606

Search for package or bug name: Reporting problems