CVE-2016-9645

NameCVE-2016-9645
DescriptionThe fix for ikiwiki for CVE-2016-10026 was incomplete resulting in editing restriction bypass for git revert when using git versions older than 2.8.0. This has been fixed in 3.20161229.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ikiwiki (PTS)jessie (security), jessie3.20141016.4fixed
stretch3.20170111fixed
buster, sid3.20180311-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ikiwikisource(unstable)3.20161229medium
ikiwikisourcejessie(not affected)
ikiwikisourcewheezy(not affected)

Notes

[jessie] - ikiwiki <not-affected> (Incomplete fix for CVE-2016-10026 not applied)
[wheezy] - ikiwiki <not-affected> (Incomplete fix for CVE-2016-10026 not applied)
https://ikiwiki.info/security/#cve-2016-9645

Search for package or bug name: Reporting problems