CVE-2016-9646

NameCVE-2016-9646
Descriptionikiwiki before 3.20161229 incorrectly called the CGI::FormBuilder->field method (similar to the CGI->param API that led to Bugzilla's CVE-2014-1572), which can be abused to lead to commit metadata forgery.
SourceCVE (at NVD; CERT, LWN, oss-sec, fulldisc, bugtraq, EDB, Metasploit, Red Hat, Ubuntu, Gentoo, SUSE bugzilla/CVE, Mageia, GitHub code/issues, web search, more)
ReferencesDLA-812-1, DSA-3760-1
NVD severitymedium (attack range: remote)

Vulnerable and fixed packages

The table below lists information on source packages.

Source PackageReleaseVersionStatus
ikiwiki (PTS)jessie (security), jessie3.20141016.4fixed
stretch3.20170111fixed
buster, sid3.20180311-1fixed

The information below is based on the following data on fixed versions.

PackageTypeReleaseFixed VersionUrgencyOriginDebian Bugs
ikiwikisource(unstable)3.20161229medium
ikiwikisourcejessie3.20141016.4mediumDSA-3760-1
ikiwikisourcewheezy3.20120629.2+deb7u2mediumDLA-812-1

Notes

https://ikiwiki.info/security/#cve-2016-9646

Search for package or bug name: Reporting problems